Station-IC: Support for MacOS versions & Processors

Question:
Which MacOS versions and CPU Processors are supported for use with Station-IC.

Answer:
Station-IC is supported for use on MacOS version 10.14 and higher (v10.16 or higher is recommended).
Station-IC requires Intel Duo Core processor at a minimum.
Station-IC is supported to run on Apple M1 processors.

Memory: 4.0GB RAM (min)

Hard disk: 1.5GB (available)

Display: 1280 x 800 (min)

 

Keep in mind:
Station-IC demo mode allows users to validate compatibility with their computers.
Station-IC can be downloaded from the Station-IC Knowledge Center.