Dynam-EC produces an error when attempting to launch with incompatible Windows language set.

Windows ‘Preferred Lanuage’ should be set as ‘English (United States)' or ‘English (United Kingdom)’ in order for Dynam-EC to launch correctly.

Navigate to ‘Windows Settings → Time and Language → Language' and make sure either ‘English (United States)' or ‘English (United Kingdom)’ is at the top of the list. (Use the up/down arrows to re-order the list).

If you try to launch Dynam-EC with an incompatible language set as the preferred language, you might see an error similar to this: